[Celestia-Testnet] mocha-4 peer connection issue


Currently running mocha-4 validator node. Keep getting following error message:

Nov 23 07:57:17 guest cosmovisor_mocha-4[3344725]: 7:57AM ERR Stopping peer for error err=“read tcp : read: connection reset by peer” module=p2p peer={“Data”:{},“Logger”:{}}

As a result LATEST_BLOCK_HEIGHT is lagging behind, and there are huge block misses. I tried to use another peers and addressbook. Worked for some time , and again started to miss blocks. Need help.

Thank you in advance

Hey there!

Can you try deleting your addrbook, remove peers, and use seeds instead to see if that helps?

For detailed instructions, refer to the documentation at:

Also, make sure that your validator node has stable and reliable network connectivity.

Hi there,

Thank you for your response!

  1. Actually already tried with addrbook, peers and seeds, but unfortunately didn’t work.
  2. Solved with following: currently mocha-4 was running with another node on the same disk. And as the result CPU was running intensively, so we moved celestia to another disk, since then (36 hours) working without any uptime issue.

Thank you